summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2021-05-15 18:57:02 -0700
committerGitHub <noreply@github.com>2021-05-15 21:57:02 -0400
commit6847f2ff0ce5827c0779a1dfcb9e6a8a657652b1 (patch)
tree2b957d6701f06720baf2cab836303400f340e6f2 /Cargo.toml
parent39c5ee991e8a02a72da398433c62f4a1b8c7acbb (diff)
refactor: split up data collection by OS (#482)
Refactor to split up data collection by OS and/or the backing library. The goal is to make it easier to work with and add new OS support, as opposed to how it was prior where we stored OS-independent implementations all in the same file.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 11e26521..13947761 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,6 +42,7 @@ chrono = "0.4.19"
crossterm = "0.18.2"
ctrlc = { version = "3.1.9", features = ["termination"] }
clap = "2.33"
+cfg-if = "1.0"
dirs-next = "2.0.0"
futures = "0.3.14"
futures-timer = "3.0.2"