summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2022-02-25 02:02:15 -0800
committerGitHub <noreply@github.com>2022-02-25 05:02:15 -0500
commit5f042aef94dc14e8ca471cb97c571530e84fbcab (patch)
tree4fe6b917024f5d51c59825e0eacb721693838745 /Cargo.toml
parentc4c9130b4a3d428ae8ad3a1903218f322820856f (diff)
deps: update procfs and testing deps (#681)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 3 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a0dc6328..f5d359d2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,8 +26,6 @@ doc = false
[profile.release]
debug = 0
lto = true
-# debug = true
-# lto = false
opt-level = 3
codegen-units = 1
strip = "symbols"
@@ -72,7 +70,7 @@ libc = "0.2.86"
[target.'cfg(target_os = "linux")'.dependencies]
heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "net", "sensors"] }
-procfs = { version = "0.11.0", default-features = false }
+procfs = { version = "0.12.0", default-features = false }
smol = "1.2.5"
[target.'cfg(target_os = "macos")'.dependencies]
@@ -83,8 +81,8 @@ heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory"] }
winapi = "0.3.9"
[dev-dependencies]
-assert_cmd = "1.0.3"
-predicates = "1.0.8"
+assert_cmd = "2.0"
+predicates = "2.1"
[build-dependencies]
clap = "2.33"