summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorWesley Moore <wes@wezm.net>2022-07-24 10:44:29 +1000
committerGitHub <noreply@github.com>2022-07-23 20:44:29 -0400
commit577fda96fc30165fe613ae2131b70844ba47c3b2 (patch)
treeb981baebc49dd47e2813ad585a0f7787da6b505b /Cargo.toml
parent510aa5c4042d9933310d24da38f08ff4647875d9 (diff)
Implement support for FreeBSD (#766)
* WIP FreeBSD support * Implement get_cpu_data_list for FreeBSD * Implement disks for FreeBSD It doesn't work though as sysinfo doesn't make the device name available. * Use libxo to read process cpu info on FreeBSD * Populate get_io_usage with libxo too Actual I/O stats still aren't populated though as there's not an easy source for them. * Share more processes code between macos and freebsd * Extract function for deserializing libxo output on FreeBSD * Implement filtering of disks in FreeBSD * Clean up memory data collection * Update module docs
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 170bd6ea..8befb5c2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -94,6 +94,9 @@ heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory", "net"] }
heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory"] }
winapi = "0.3.9"
+[target.'cfg(target_os = "freebsd")'.dependencies]
+serde_json = { version = "1.0.82" }
+
[dev-dependencies]
assert_cmd = "2.0.4"
predicates = "2.1.1"