summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2022-05-06 17:16:57 -0400
committerGitHub <noreply@github.com>2022-05-06 17:16:57 -0400
commit4ceaf8d00894a7b9fb84581aa5ec05568142c8fb (patch)
tree419098e3c1bf3dc90d9b1283fe7b895254c26ffe /Cargo.toml
parent9d6d712e27fa6b90f505e214bd039865e63214e5 (diff)
deps: migrate to starship-battery (#724)
Migrates the `battery` dependency to the more actively maintained `starship-battery` fork, found at https://github.com/starship/rust-battery. See https://github.com/svartalf/rust-battery/pull/92 for more information.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e7b8477a..b7b7b5fe 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -32,6 +32,7 @@ strip = "symbols"
[features]
default = ["fern", "log", "battery", "gpu"]
+battery = ["starship-battery"]
deploy = ["battery", "gpu"]
gpu = ["nvidia"]
nvidia = ["nvml-wrapper"]
@@ -64,7 +65,7 @@ unicode-width = "0.1.9"
fern = { version = "0.6.1", optional = true }
log = { version = "0.4.16", optional = true }
-battery = { version = "0.7.8", optional = true }
+starship-battery = { version = "0.7.9", optional = true }
nvml-wrapper = { version = "0.7.0", optional = true }
[target.'cfg(unix)'.dependencies]