summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClementTsang <cjhtsang@uwaterloo.ca>2020-02-06 21:47:47 -0500
committerClementTsang <cjhtsang@uwaterloo.ca>2020-02-06 21:47:47 -0500
commitfc37cf7f3dccaae6065a81ad5cfc869e9f74c23f (patch)
treead9d69d099b410834982ce1f7c540b67a4f0d235 /Cargo.toml
parent8782b327b9aae181e4fd99a8936ac9bf0a4b51a3 (diff)
Config with toml instead
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2224d80a..1a9bccbc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,7 +23,6 @@ lto = true
[dependencies]
chrono = "0.4.10"
clap = "2.33.0"
-crossterm = "0.14"
failure = "0.1.6"
fern = "0.5.9"
futures-timer = "3.0.1"
@@ -34,10 +33,12 @@ regex = "1.3.4"
sysinfo = "0.10.5"
tokio = "0.2.11"
winapi = "0.3.8"
+crossterm = "0.14"
tui = {version = "0.8", features = ["crossterm"], default-features = false }
lazy_static = "1.4.0"
backtrace = "0.3"
-yaml-rust = "0.4.3"
+toml = "0.5.6"
+serde = "1.0"
[dev-dependencies]
assert_cmd = "0.12"