summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-06-28 10:45:56 -0400
committerGitHub <noreply@github.com>2023-06-28 10:45:56 -0400
commitfc027ece68bac2b1f833ff839e0366097e91c2c6 (patch)
treef027c08a562f85c7d6fbacdf6b6a6d8edfb53096 /Cargo.toml
parentb392f4b70622d2a9debef6c5fad53b0a805682fc (diff)
deps: bump deps as of 2023-06-27 (#1232)
Bumps: - clap - indexmap - itertools - libc - serde_json - toml_edit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8813e73a..2b4e8f51 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -78,7 +78,7 @@ logging = ["fern", "log"]
anyhow = "1.0.71"
backtrace = "0.3.67"
cfg-if = "1.0.0"
-clap = { version = "4.3.4", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.8", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.26.1"
ctrlc = { version = "3.4.0", features = ["termination"] }
@@ -88,8 +88,8 @@ fern = { version = "0.6.2", optional = true }
hashbrown = "0.14.0"
humantime = "2.1.0"
humantime-serde = "1.1.1"
-indexmap = "1.9.3"
-itertools = "0.10.5"
+indexmap = "2.0.0"
+itertools = "0.11.0"
kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.18", optional = true }
nvml-wrapper = { version = "0.9.0", optional = true }
@@ -100,13 +100,13 @@ starship-battery = { version = "0.8.1", optional = true }
sysinfo = "=0.29.2"
thiserror = "1.0.40"
time = { version = "0.3.22", features = ["formatting", "macros"] }
-toml_edit = { version = "0.19.10", features = ["serde"] }
+toml_edit = { version = "0.19.11", features = ["serde"] }
tui = { version = "0.21.0", package = "ratatui" }
unicode-segmentation = "1.10.1"
unicode-width = "0.1.10"
[target.'cfg(unix)'.dependencies]
-libc = "0.2.146"
+libc = "0.2.147"
[target.'cfg(target_os = "linux")'.dependencies]
rustix = { version = "0.37.20", features = ["fs", "param", "process"] }
@@ -127,7 +127,7 @@ windows = { version = "0.48.0", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.97" }
+serde_json = { version = "1.0.99" }
sysctl = { version = "0.5.4" }
filedescriptor = "0.8.2"
@@ -137,7 +137,7 @@ cargo-husky = { version = "1.5.0", default-features = false, features = ["user-h
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.3.4", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.8", features = ["default", "cargo", "wrap_help"] }
clap_complete = "4.3.1"
clap_mangen = "0.2.12"