summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2021-05-13 20:41:43 -0700
committerGitHub <noreply@github.com>2021-05-13 23:41:43 -0400
commitee6228c2b61c0d20e32df610765838634e1a6361 (patch)
tree1a47a59c3d628bd4dbc203aa31a2ffbe18f3ce5f /Cargo.toml
parent1e7668fcaa990d57529bebb321f71aba0263a483 (diff)
refactor: switch to procfs library (#479)
Switch the Linux proc parts to the procfs library: https://crates.io/crates/procfs.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 14 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0dfa4602..11e26521 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -61,17 +61,18 @@ unicode-segmentation = "1.7.1"
unicode-width = "0.1"
# For debugging only... disable on release builds with --no-default-target for no? TODO: Redo this.
-fern = { version = "0.6.0", optional=true }
-log = { version = "0.4.14", optional=true }
+fern = { version = "0.6.0", optional = true }
+log = { version = "0.4.14", optional = true }
[target.'cfg(unix)'.dependencies]
libc = "0.2.86"
[target.'cfg(target_os = "linux")'.dependencies]
heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory", "net", "sensors"] }
+procfs = "0.9.1"
[target.'cfg(target_os = "macos")'.dependencies]
-heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory", "net"] }
+heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory", "net"] }
[target.'cfg(target_os = "windows")'.dependencies]
heim = { version = "0.1.0-rc.1", features = ["cpu", "disk", "memory"] }
@@ -89,8 +90,16 @@ section = "utility"
assets = [
["target/release/btm", "usr/bin/", "755"],
["LICENSE", "usr/share/doc/btm/", "644"],
- ["completion/btm.bash", "usr/share/bash-completion/completions/btm", "644"],
- ["completion/btm.fish", "usr/share/fish/vendor_completions.d/btm.fish", "644"],
+ [
+ "completion/btm.bash",
+ "usr/share/bash-completion/completions/btm",
+ "644",
+ ],
+ [
+ "completion/btm.fish",
+ "usr/share/fish/vendor_completions.d/btm.fish",
+ "644",
+ ],
["completion/_btm", "usr/share/zsh/vendor-completions/", "644"],
]
extended-description = """\
@@ -109,4 +118,3 @@ output = "bottom_x86_64_installer.msi"
version = "1"
default-features = false
features = ["user-hooks"]
-