summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2024-01-15 04:19:18 -0500
committerGitHub <noreply@github.com>2024-01-15 04:19:18 -0500
commitdd66ae774ca9a93a2c1bd471e3b1ba2075044f15 (patch)
tree8c6c76195150944da8a42b7131b65acb8f78918c /Cargo.toml
parentf093902aef3954bef79fa348c46e1bf3949675cf (diff)
refactor: simplify some config -> constraints code (#1383)
* refactor: simplify some config -> constraints code * iteratively progress... * update bcr; this might need testing since I removed some old proc code * widget side * fix battery * fix widget tests with bandaid for now The issue was that the calculations assume a certain ratio for CPU legends. * add some tests * bump up * fix proc drawing issues So with the proc widget in certain places, there would be a panic during constraint determination. Looks like back when I wrote this I made some gross assumptions about certain things. In particular, the problem here was that the search added an additional "one" height, so that needs to be accounted for after we removed the "doubling" code. * tests * fix tests * reorganize tests * clippy * fix cross tests not working * fix builds for android
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 39a0cfce..45805ddc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -135,6 +135,9 @@ cargo-husky = { version = "1.5.0", default-features = false, features = [
] }
predicates = "3.0.3"
+[target.'cfg(all(target_arch = "x86_64", target_os = "linux"))'.dev-dependencies]
+portable-pty = "0.8.1"
+
[build-dependencies]
clap = { version = "4.4.14", features = ["default", "cargo", "wrap_help"] }
clap_complete = "4.4.6"