summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-07-24 04:02:59 -0400
committerGitHub <noreply@github.com>2023-07-24 04:02:59 -0400
commitdbf054506f827c29d4508a6f07ac2e4ee4dad00f (patch)
tree5ac88417ce9443b30ac58ba120580afc86553643 /Cargo.toml
parent0e8feca616e86931c66e7d6db5d539dfa7a5672a (diff)
deps: bump dependencies as of 2023-07-24 (#1265)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 491d4b1b..b9611b8f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -77,7 +77,7 @@ default = ["deploy"]
anyhow = "1.0.72"
backtrace = "0.3.68"
cfg-if = "1.0.0"
-clap = { version = "4.3.17", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.19", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.26.1"
ctrlc = { version = "3.4.0", features = ["termination"] }
@@ -93,10 +93,10 @@ log = { version = "0.4.19", optional = true }
nvml-wrapper = { version = "0.9.0", optional = true }
once_cell = "1.18.0"
regex = "1.9.1"
-serde = { version = "1.0.173", features = ["derive"] }
+serde = { version = "1.0.175", features = ["derive"] }
starship-battery = { version = "0.8.1", optional = true }
sysinfo = "=0.29.6"
-thiserror = "1.0.43"
+thiserror = "1.0.44"
time = { version = "0.3.23", features = ["formatting", "macros"] }
toml_edit = { version = "0.19.14", features = ["serde"] }
tui = { version = "0.22.0", package = "ratatui" }
@@ -137,7 +137,7 @@ cargo-husky = { version = "1.5.0", default-features = false, features = [
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.3.17", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.19", features = ["default", "cargo", "wrap_help"] }
clap_complete = "4.3.2"
clap_mangen = "0.2.12"