summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-07-20 02:25:02 -0400
committerGitHub <noreply@github.com>2023-07-20 02:25:02 -0400
commitd2b945957f7310b838cf5f6c3ed737ea8f4f2711 (patch)
tree7f4cb74d3bf2511abedfdefb1000ec7e52754936 /Cargo.toml
parent0b0f0040019f57e8df4bad8a69a42dfe3a64d82f (diff)
deps: bump some dependencies as of 2023-07-19 (#1260)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2b437eeb..d8e4f1a5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -74,10 +74,10 @@ deploy = ["battery", "gpu", "zfs"]
default = ["deploy"]
[dependencies]
-anyhow = "1.0.71"
+anyhow = "1.0.72"
backtrace = "0.3.68"
cfg-if = "1.0.0"
-clap = { version = "4.3.10", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.17", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.26.1"
ctrlc = { version = "3.4.0", features = ["termination"] }
@@ -93,12 +93,12 @@ log = { version = "0.4.19", optional = true }
nvml-wrapper = { version = "0.9.0", optional = true }
once_cell = "1.18.0"
regex = "1.9.1"
-serde = { version = "1.0.171", features = ["derive"] }
+serde = { version = "1.0.173", features = ["derive"] }
starship-battery = { version = "0.8.1", optional = true }
sysinfo = "=0.29.5"
thiserror = "1.0.43"
time = { version = "0.3.23", features = ["formatting", "macros"] }
-toml_edit = { version = "0.19.12", features = ["serde"] }
+toml_edit = { version = "0.19.14", features = ["serde"] }
tui = { version = "0.21.0", package = "ratatui" }
unicode-segmentation = "1.10.1"
unicode-width = "0.1.10"
@@ -125,19 +125,19 @@ windows = { version = "0.48.0", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.102" }
+serde_json = { version = "1.0.103" }
sysctl = { version = "0.5.4" }
filedescriptor = "0.8.2"
[dev-dependencies]
-assert_cmd = "2.0.11"
+assert_cmd = "2.0.12"
cargo-husky = { version = "1.5.0", default-features = false, features = [
"user-hooks",
] }
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.3.11", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.17", features = ["default", "cargo", "wrap_help"] }
clap_complete = "4.3.2"
clap_mangen = "0.2.12"