summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2024-03-23 02:33:15 -0400
committerGitHub <noreply@github.com>2024-03-23 02:33:15 -0400
commitc651e9a904bf25a95cbda20846115d4bf08de73d (patch)
tree688ad31ba6e17a0e28889402cc6658854151300d /Cargo.toml
parent2238d49c6ca8c94fed188a59ac787caa8d231fcc (diff)
deps: bump dependencies as of 2024-03-23 (#1431)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cd914b5d..139f1533 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -72,30 +72,30 @@ deploy = ["battery", "gpu", "zfs"]
default = ["deploy"]
[dependencies]
-anyhow = "1.0.80"
-backtrace = "0.3.69"
+anyhow = "1.0.81"
+backtrace = "0.3.71"
cfg-if = "1.0.0"
clap = { version = "=4.4.18", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.27.0"
-ctrlc = { version = "3.4.2", features = ["termination"] }
+ctrlc = { version = "3.4.4", features = ["termination"] }
dirs = "5.0.1"
fern = { version = "0.6.2", optional = true }
hashbrown = "0.14.3"
humantime = "2.1.0"
-indexmap = "2.2.5"
-indoc = "2.0.4"
+indexmap = "2.2.6"
+indoc = "2.0.5"
itertools = "0.12.1"
kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.21", optional = true }
nvml-wrapper = { version = "0.10.0", optional = true, features = ["legacy-functions"] }
-regex = "1.10.3"
+regex = "1.10.4"
serde = { version = "1.0.197", features = ["derive"] }
starship-battery = { version = "0.8.2", optional = true }
sysinfo = "=0.30.7"
-thiserror = "1.0.57"
+thiserror = "1.0.58"
time = { version = "0.3.34", features = ["formatting", "macros"] }
-toml_edit = { version = "0.22.6", features = ["serde"] }
+toml_edit = { version = "0.22.9", features = ["serde"] }
tui = { version = "0.26.1", package = "ratatui" }
unicode-segmentation = "1.11.0"
unicode-width = "0.1.11"
@@ -104,7 +104,7 @@ unicode-width = "0.1.11"
libc = "0.2.153"
[target.'cfg(target_os = "linux")'.dependencies]
-rustix = { version = "0.38.31", features = ["fs", "param", "process"] }
+rustix = { version = "0.38.32", features = ["fs", "param", "process"] }
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.9.4"
@@ -140,7 +140,7 @@ clap_complete = "=4.4.10"
clap_complete_fig = "=4.4.2"
clap_complete_nushell = "=4.4.2"
clap_mangen = "=0.2.19"
-indoc = "2.0.4"
+indoc = "2.0.5"
[package.metadata.deb]
section = "utility"