summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-06-17 05:48:59 +0000
committerGitHub <noreply@github.com>2023-06-17 01:48:59 -0400
commit8d078f8d71a5d56d2f5344a02a7a3400a534ae2c (patch)
treed7b24a7eaaeea42c717fca1594800887d5f7cb8e /Cargo.toml
parentc73bc2cdb415a97ea5c2461203b841a7fc90402c (diff)
deps: bump clap, rustix, serde_json (#1210)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 175e04c0..dfd8b9b2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -78,7 +78,7 @@ logging = ["fern", "log"]
anyhow = "1.0.71"
backtrace = "0.3.67"
cfg-if = "1.0.0"
-clap = { version = "4.3.3", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.4", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.26.1"
ctrlc = { version = "3.4.0", features = ["termination"] }
@@ -109,7 +109,7 @@ unicode-width = "0.1.10"
libc = "0.2.146"
[target.'cfg(target_os = "linux")'.dependencies]
-rustix = { version = "0.37.19", features = ["fs", "param", "process"] }
+rustix = { version = "0.37.20", features = ["fs", "param", "process"] }
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.9.3"
@@ -127,7 +127,7 @@ windows = { version = "0.48.0", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.96" }
+serde_json = { version = "1.0.97" }
sysctl = { version = "0.5.4" }
filedescriptor = "0.8.2"
@@ -139,7 +139,7 @@ cargo-husky = { version = "1.5.0", default-features = false, features = [
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.3.3", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.4", features = ["default", "cargo", "wrap_help"] }
clap_complete = "4.3.1"
clap_mangen = "0.2.12"