summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-07-03 00:47:02 -0400
committerGitHub <noreply@github.com>2023-07-03 00:47:02 -0400
commit7240661aabb188485ee4024ba9c8b92ad0052b5c (patch)
tree9bc13dd1e8fb13ccc24ffbeb3ed333aeaf6a61b4 /Cargo.toml
parentdf3088e80ef223d9cd921568ae9bb31d7a3c9767 (diff)
deps: bump dependencies as of 2023-07-03 (#1240)
* deps: bump deps as of 2023-07-02 * run cargo update
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3ca300de..0128bb2a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -75,9 +75,9 @@ default = ["deploy"]
[dependencies]
anyhow = "1.0.71"
-backtrace = "0.3.67"
+backtrace = "0.3.68"
cfg-if = "1.0.0"
-clap = { version = "4.3.9", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.10", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.26.1"
ctrlc = { version = "3.4.0", features = ["termination"] }
@@ -96,7 +96,7 @@ once_cell = "1.18.0"
regex = "1.8.4"
serde = { version = "1.0.164", features = ["derive"] }
starship-battery = { version = "0.8.1", optional = true }
-sysinfo = "=0.29.2"
+sysinfo = "0.29.3"
thiserror = "1.0.40"
time = { version = "0.3.22", features = ["formatting", "macros"] }
toml_edit = { version = "0.19.11", features = ["serde"] }
@@ -108,7 +108,7 @@ unicode-width = "0.1.10"
libc = "0.2.147"
[target.'cfg(target_os = "linux")'.dependencies]
-rustix = { version = "0.38.0", features = ["fs", "param", "process"] }
+rustix = { version = "0.38.1", features = ["fs", "param", "process"] }
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.9.3"
@@ -136,7 +136,7 @@ cargo-husky = { version = "1.5.0", default-features = false, features = ["user-h
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.3.9", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.10", features = ["default", "cargo", "wrap_help"] }
clap_complete = "4.3.1"
clap_mangen = "0.2.12"