summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2022-01-27 16:16:27 -0800
committerGitHub <noreply@github.com>2022-01-27 19:16:27 -0500
commit6c989785fb458a8d7933f98050148e0faf45a8ba (patch)
tree94562a1e352cb7edcb537576c4b60e62117b13b9 /Cargo.toml
parent255b69c15fa3d997737c5e1b51d480c45cb0fe4d (diff)
bug: fix issues caused by having a width that is too small (#665)
Due to a missing check, you could resize the window to a width that was too small, and it would trigger an endless while-loop for any table while trying to redistribute remaining space. This has been rectified with an explicit check, as well as a smarter method of redistributing remaining space borrowed from the rewrite. This also adds explicit width checks for widgets that have borders; if the width is <2, before, it would panic. Note that the rewrite I have kinda fixes all these issues already, so I don't want to invest too hard into this, but this should be fine as a patch for now. Also note that minimal heights don't seem to be causing any issues, it just seems to be minimal widths.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index eb0f399f..9d56e94e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,7 +19,7 @@ path = "src/bin/main.rs"
doc = false
[lib]
-test = false
+test = true
doctest = false
doc = false