summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-08-09 01:27:56 -0400
committerGitHub <noreply@github.com>2023-08-09 01:27:56 -0400
commit619e9d9c1b289276ffe04fbcd82624bc5afad495 (patch)
tree038bba419b64afedb9def5afd86a24e862fcfd92 /Cargo.toml
parent07b7caa5fa4080f91af8a448f28456fb95f36722 (diff)
deps: bump deps as of 2023-08-08 (#1272)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 396ec544..b994b7a6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "bottom"
-version = "0.9.4"
+version = "0.9.5"
authors = ["Clement Tsang <cjhtsang@uwaterloo.ca>"]
edition = "2021"
repository = "https://github.com/ClementTsang/bottom"
@@ -77,9 +77,9 @@ default = ["deploy"]
anyhow = "1.0.72"
backtrace = "0.3.68"
cfg-if = "1.0.0"
-clap = { version = "4.3.19", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.21", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
-crossterm = "0.26.1"
+crossterm = "0.27.0"
ctrlc = { version = "3.4.0", features = ["termination"] }
# dhat = "0.3.2"
dirs = "5.0.1"
@@ -92,12 +92,12 @@ kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.19", optional = true }
nvml-wrapper = { version = "0.9.0", optional = true }
once_cell = "1.18.0"
-regex = "1.9.1"
-serde = { version = "1.0.175", features = ["derive"] }
-starship-battery = { version = "0.8.1", optional = true }
+regex = "1.9.3"
+serde = { version = "1.0.183", features = ["derive"] }
+starship-battery = { version = "0.8.2", optional = true }
sysinfo = "=0.29.7"
thiserror = "1.0.44"
-time = { version = "0.3.23", features = ["formatting", "macros"] }
+time = { version = "0.3.25", features = ["formatting", "macros"] }
toml_edit = { version = "0.19.14", features = ["serde"] }
tui = { version = "0.22.0", package = "ratatui" }
unicode-segmentation = "1.10.1"
@@ -107,7 +107,7 @@ unicode-width = "0.1.10"
libc = "0.2.147"
[target.'cfg(target_os = "linux")'.dependencies]
-rustix = { version = "0.38.4", features = ["fs", "param", "process"] }
+rustix = { version = "0.38.7", features = ["fs", "param", "process"] }
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.9.3"
@@ -125,7 +125,7 @@ windows = { version = "0.48.0", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.103" }
+serde_json = { version = "1.0.104" }
sysctl = { version = "0.5.4" }
filedescriptor = "0.8.2"
@@ -137,7 +137,7 @@ cargo-husky = { version = "1.5.0", default-features = false, features = [
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.3.19", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.3.21", features = ["default", "cargo", "wrap_help"] }
clap_complete = "4.3.2"
clap_mangen = "0.2.12"