summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2020-12-12 21:06:46 -0500
committerGitHub <noreply@github.com>2020-12-12 21:06:46 -0500
commit5d7697d3da6e9e481bca38fc6e1d28e8e48ff2ee (patch)
treef743bceb03c08cccb432cfa45e954f8e3b599781 /Cargo.toml
parent766fe25c55b1a3776dc94daccbe0505c5cdfb0a1 (diff)
refactor: More minor optimization changes (#353)
- Move data rather than cloning during data transferring step - Try using beef?
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 96a692f3..ed2166c1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,10 +18,10 @@ path = "src/bin/main.rs"
doc = false
[profile.release]
-debug = 1
-lto = true
-# debug = true
-# lto = false
+# debug = 1
+# lto = true
+debug = true
+lto = false
opt-level = 3
codegen-units = 1
@@ -32,6 +32,7 @@ default = ["fern", "log"]
anyhow = "1.0.34"
backtrace = "0.3"
battery = "0.7.8"
+beef = "0.4.4"
chrono = "0.4.19"
crossterm = "0.18.2"
ctrlc = { version = "3.1", features = ["termination"] }