summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2024-01-21 05:47:13 -0500
committerGitHub <noreply@github.com>2024-01-21 05:47:13 -0500
commit5cf17f6015e8fce5a8a0799c70e7a032b7f024ad (patch)
tree033e029966813e74b306819575f2aa20953bdbd4 /Cargo.toml
parent975e3d776bad3d0111394ae7871b96c513b4f10c (diff)
other: flatten process config struct and clean up help text (#1395)
* refactor: flatten process config field * other: clean up some doc formatting using indoc and breaklines * fix broken test * remove default as that breaks things for now * add test * more tests
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index af2cfd2d..b0007203 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -75,7 +75,7 @@ default = ["deploy"]
anyhow = "1.0.79"
backtrace = "0.3.69"
cfg-if = "1.0.0"
-clap = { version = "4.4.16", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.4.18", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.27.0"
ctrlc = { version = "3.4.2", features = ["termination"] }
@@ -85,6 +85,7 @@ fern = { version = "0.6.2", optional = true }
hashbrown = "0.14.3"
humantime = "2.1.0"
indexmap = "2.1.0"
+indoc = "2.0.4"
itertools = "0.12.0"
kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.20", optional = true }
@@ -139,11 +140,12 @@ predicates = "3.0.4"
portable-pty = "0.8.1"
[build-dependencies]
-clap = { version = "4.4.16", features = ["default", "cargo", "wrap_help"] }
-clap_complete = "4.4.6"
+clap = { version = "4.4.18", features = ["default", "cargo", "wrap_help"] }
+clap_complete = "4.4.8"
clap_complete_fig = "4.4.2"
clap_complete_nushell = "4.4.2"
clap_mangen = "0.2.17"
+indoc = "2.0.4"
[package.metadata.deb]
section = "utility"