summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2021-04-05 01:19:17 -0400
committerGitHub <noreply@github.com>2021-04-05 01:19:17 -0400
commit5bd9e4f6ae399a702508b45a02e74d07e9bb7c77 (patch)
tree110ea41c5a207e444c31688cfb2502a992814527 /Cargo.toml
parent405ce64a02fd55ebb383ce797910b2ec82dc97b4 (diff)
feature: Collapsing in tree mode sums usage to parent (#445)
For the process widget, we now sum the resource usage of the child processes on the parent entry when collapsing in tree mode. Note that if you search to filter, and collapse, it will not sum the pruned values (values that cannot be seen). This is partly because I'm a bit lazy, and partly because I think this behaviour makes sense. For example, let's say I search for a process with 4 child processes "AA, AB, BA, BB", with CPU usage 0.1, 0.2, 0.3, 0.4 respectively. Assume the parent process has 0 usage. - Without filter, it sums to 1.0 - With a filter on A, it would sum to just 0.3 - With a filter on AA, it would sum to 0.1 I think this is fine because I'm treating this as summing any child that is still *visible* somehow. Summing unseen values would probably be weird as it would look like it's not adding up. Further note that if you had, say, a child "CC" with a usage of, say, 2.0, and its parent of "AB", and you searched for CC in our above example, you would get a sum of 2.2. This is because AB is still visible by the fact that CC was the searched process, and AB must still exist (albeit faded out) in the tree hierarchy, and as such will still be displayed.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 108c3225..3df2473b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -43,8 +43,8 @@ crossterm = "0.18.2"
ctrlc = { version = "3.1", features = ["termination"] }
clap = "2.33"
dirs-next = "2.0.0"
-fxhash = "0.2.1"
futures = "0.3.12"
+fxhash = "0.2.1"
indexmap = "~1.6"
itertools = "0.10.0"
once_cell = "1.5.2"