summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-07-06 07:33:30 -0400
committerGitHub <noreply@github.com>2023-07-06 07:33:30 -0400
commit567ba3760bd3bf21a8d48a8373e8c61a98747bf0 (patch)
treee20b8a712177091e05919e0118856169907ef9f1 /Cargo.toml
parenta10b91239bfd46bc4216e5aa27099e8511ca1dfd (diff)
deps: bump deps as of 2023-07-06 (#1246)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0128bb2a..40acc261 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -93,13 +93,13 @@ kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.19", optional = true }
nvml-wrapper = { version = "0.9.0", optional = true }
once_cell = "1.18.0"
-regex = "1.8.4"
-serde = { version = "1.0.164", features = ["derive"] }
+regex = "1.9.0"
+serde = { version = "1.0.166", features = ["derive"] }
starship-battery = { version = "0.8.1", optional = true }
sysinfo = "0.29.3"
-thiserror = "1.0.40"
+thiserror = "1.0.41"
time = { version = "0.3.22", features = ["formatting", "macros"] }
-toml_edit = { version = "0.19.11", features = ["serde"] }
+toml_edit = { version = "0.19.12", features = ["serde"] }
tui = { version = "0.21.0", package = "ratatui" }
unicode-segmentation = "1.10.1"
unicode-width = "0.1.10"
@@ -108,7 +108,7 @@ unicode-width = "0.1.10"
libc = "0.2.147"
[target.'cfg(target_os = "linux")'.dependencies]
-rustix = { version = "0.38.1", features = ["fs", "param", "process"] }
+rustix = { version = "0.38.3", features = ["fs", "param", "process"] }
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.9.3"
@@ -126,7 +126,7 @@ windows = { version = "0.48.0", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.99" }
+serde_json = { version = "1.0.100" }
sysctl = { version = "0.5.4" }
filedescriptor = "0.8.2"
@@ -136,8 +136,8 @@ cargo-husky = { version = "1.5.0", default-features = false, features = ["user-h
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.3.10", features = ["default", "cargo", "wrap_help"] }
-clap_complete = "4.3.1"
+clap = { version = "4.3.11", features = ["default", "cargo", "wrap_help"] }
+clap_complete = "4.3.2"
clap_mangen = "0.2.12"
[package.metadata.deb]