summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-07-12 03:44:09 -0400
committerGitHub <noreply@github.com>2023-07-12 03:44:09 -0400
commit53c51c7c83732cfd1bfc6d10b0cedec26a27d3a3 (patch)
tree23fbbf72fe05cf3484aaa317e83c5f7f1fe38b9c /Cargo.toml
parentb0cb308106c91eb7fb8a028be1d34f54c7729281 (diff)
deps: clean and update dpes in Cargo.toml (#1254)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8c54b1b5..60ca2e81 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -86,7 +86,6 @@ dirs = "5.0.1"
fern = { version = "0.6.2", optional = true }
hashbrown = "0.14.0"
humantime = "2.1.0"
-humantime-serde = "1.1.1"
indexmap = "2.0.0"
itertools = "0.11.0"
kstring = { version = "2.0.0", features = ["arc"] }
@@ -94,11 +93,11 @@ log = { version = "0.4.19", optional = true }
nvml-wrapper = { version = "0.9.0", optional = true }
once_cell = "1.18.0"
regex = "1.9.1"
-serde = { version = "1.0.168", features = ["derive"] }
+serde = { version = "1.0.171", features = ["derive"] }
starship-battery = { version = "0.8.1", optional = true }
sysinfo = "=0.29.4"
thiserror = "1.0.43"
-time = { version = "0.3.22", features = ["formatting", "macros"] }
+time = { version = "0.3.23", features = ["formatting", "macros"] }
toml_edit = { version = "0.19.12", features = ["serde"] }
tui = { version = "0.21.0", package = "ratatui" }
unicode-segmentation = "1.10.1"
@@ -108,7 +107,7 @@ unicode-width = "0.1.10"
libc = "0.2.147"
[target.'cfg(target_os = "linux")'.dependencies]
-rustix = { version = "0.38.3", features = ["fs", "param", "process"] }
+rustix = { version = "0.38.4", features = ["fs", "param", "process"] }
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.9.3"
@@ -126,13 +125,15 @@ windows = { version = "0.48.0", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.100" }
+serde_json = { version = "1.0.102" }
sysctl = { version = "0.5.4" }
filedescriptor = "0.8.2"
[dev-dependencies]
assert_cmd = "2.0.11"
-cargo-husky = { version = "1.5.0", default-features = false, features = ["user-hooks"] }
+cargo-husky = { version = "1.5.0", default-features = false, features = [
+ "user-hooks",
+] }
predicates = "3.0.3"
[build-dependencies]