summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2024-04-11 05:53:36 +0000
committerGitHub <noreply@github.com>2024-04-11 01:53:36 -0400
commit53a01ad8744640d2fb4078784a0be327449b7057 (patch)
treed6f97406b02f2b7315b7b2a1f893948cf5bfe19d /Cargo.toml
parentaa3f80bcfa812aaa8a9bac197419cf3f4f373b12 (diff)
deps: bump clap-related dependencies, increase unofficial msrv to 1.74 (#1445)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cad5e1b7..b89c4ad7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,7 +31,7 @@ exclude = [
"Cross.toml",
"rustfmt.toml",
]
-rust-version = "1.70.0" # The oldest version I've tested that should still build bottom - note this is not an official MSRV!
+rust-version = "1.74.0" # The oldest version I've tested that should still build - note this is not an official MSRV!
[[bin]]
name = "btm"
@@ -75,7 +75,7 @@ default = ["deploy"]
anyhow = "1.0.82"
backtrace = "0.3.71"
cfg-if = "1.0.0"
-clap = { version = "=4.4.18", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.5.4", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.27.0"
ctrlc = { version = "3.4.4", features = ["termination"] }
@@ -135,11 +135,11 @@ predicates = "3.1.0"
portable-pty = "0.8.1"
[build-dependencies]
-clap = { version = "=4.4.18", features = ["default", "cargo", "wrap_help"] }
-clap_complete = "=4.4.10"
-clap_complete_fig = "=4.4.2"
-clap_complete_nushell = "=4.4.2"
-clap_mangen = "=0.2.19"
+clap = { version = "4.5.4", features = ["default", "cargo", "wrap_help"] }
+clap_complete = "4.5.2"
+clap_complete_nushell = "4.5.1"
+clap_complete_fig = "4.5.0"
+clap_mangen = "0.2.20"
indoc = "2.0.5"
[package.metadata.deb]