summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-11-28 04:06:51 +0000
committerGitHub <noreply@github.com>2023-11-27 23:06:51 -0500
commit2db881e3cfe939e78173671a2696238813cd3465 (patch)
tree83d2570cf28734cb491572153bcb968b2a3d8aaf /Cargo.toml
parentcf447e6a4ee7a9ac898f85e379e4acbedcda595e (diff)
deps: bump dependencies as of 2023-11-27 (#1338)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml44
1 files changed, 23 insertions, 21 deletions
diff --git a/Cargo.toml b/Cargo.toml
index afbeef85..07fafc3f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -80,44 +80,46 @@ default = ["deploy"]
anyhow = "1.0.75"
backtrace = "0.3.69"
cfg-if = "1.0.0"
-clap = { version = "4.4.2", features = ["default", "cargo", "wrap_help"] }
+clap = { version = "4.4.10", features = ["default", "cargo", "wrap_help"] }
concat-string = "1.0.1"
crossterm = "0.27.0"
-ctrlc = { version = "3.4.0", features = ["termination"] }
+ctrlc = { version = "3.4.1", features = ["termination"] }
# dhat = "0.3.2"
dirs = "5.0.1"
fern = { version = "0.6.2", optional = true }
-hashbrown = "0.14.0"
+hashbrown = "0.14.3"
humantime = "2.1.0"
-indexmap = "2.0.0"
-itertools = "0.11.0"
+indexmap = "2.1.0"
+itertools = "0.12.0"
kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.20", optional = true }
-nvml-wrapper = { version = "0.9.0", optional = true, features = ["legacy-functions"] }
+nvml-wrapper = { version = "0.9.0", optional = true, features = [
+ "legacy-functions",
+] }
once_cell = "1.18.0"
-regex = "1.9.4"
-serde = { version = "=1.0.188 ", features = ["derive"] }
+regex = "1.10.2"
+serde = { version = "=1.0.193", features = ["derive"] }
starship-battery = { version = "0.8.2", optional = true }
sysinfo = "=0.29.11"
-thiserror = "1.0.47"
-time = { version = "0.3.26", features = ["formatting", "macros"] }
+thiserror = "1.0.50"
+time = { version = "0.3.30", features = ["formatting", "macros"] }
toml_edit = { version = "0.21.0", features = ["serde"] }
tui = { version = "0.22.0", package = "ratatui" }
unicode-segmentation = "1.10.1"
-unicode-width = "0.1.10"
+unicode-width = "0.1.11"
[target.'cfg(unix)'.dependencies]
-libc = "0.2.147"
+libc = "0.2.150"
[target.'cfg(target_os = "linux")'.dependencies]
-rustix = { version = "0.38.9", features = ["fs", "param", "process"] }
+rustix = { version = "0.38.25", features = ["fs", "param", "process"] }
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.9.3"
mach2 = "0.4.1"
[target.'cfg(target_os = "windows")'.dependencies]
-windows = { version = "0.51.1", features = [
+windows = { version = "0.52.0", features = [
"Win32_Foundation",
"Win32_Security",
"Win32_Storage_FileSystem",
@@ -128,8 +130,8 @@ windows = { version = "0.51.1", features = [
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.105" }
-sysctl = { version = "0.5.4" }
+serde_json = { version = "1.0.108" }
+sysctl = { version = "0.5.5" }
filedescriptor = "0.8.2"
[dev-dependencies]
@@ -140,11 +142,11 @@ cargo-husky = { version = "1.5.0", default-features = false, features = [
predicates = "3.0.3"
[build-dependencies]
-clap = { version = "4.4.2", features = ["default", "cargo", "wrap_help"] }
-clap_complete = "4.4.1"
-clap_complete_fig = "4.4.0"
-clap_complete_nushell = "4.4.0"
-clap_mangen = "0.2.13"
+clap = { version = "4.4.10", features = ["default", "cargo", "wrap_help"] }
+clap_complete = "4.4.4"
+clap_complete_fig = "4.4.2"
+clap_complete_nushell = "4.4.2"
+clap_mangen = "0.2.15"
[package.metadata.deb]
section = "utility"