summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClement Tsang <34804052+ClementTsang@users.noreply.github.com>2023-03-28 01:14:10 -0400
committerGitHub <noreply@github.com>2023-03-28 01:14:10 -0400
commitbde2dac56ec5a5ff7d35034d37a9ec2de026ccfe (patch)
treefac22a717e5934e897e5772ed5f113d230672f3b /Cargo.toml
parent444d2f7ad7707925c0d2f44e45162ae7371dc310 (diff)
deps: bump various dependencies as of 2023-03-27 (#1079)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 12 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 89bdc397..836eff66 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -72,7 +72,7 @@ default = ["fern", "log", "battery", "gpu", "zfs"]
deploy = ["battery", "gpu", "zfs"]
[dependencies]
-anyhow = "1.0.69"
+anyhow = "1.0.70"
backtrace = "0.3.67"
cfg-if = "1.0.0"
clap = { version = "3.2.2", features = ["default", "cargo", "wrap_help"] }
@@ -80,33 +80,33 @@ concat-string = "1.0.1"
const_format = "0.2.30"
crossterm = "0.26.1"
ctrlc = { version = "3.2.5", features = ["termination"] }
-dirs = "4.0.0"
-fern = { version = "0.6.1", optional = true }
+dirs = "5.0.0"
+fern = { version = "0.6.2", optional = true }
futures = "0.3.26"
futures-timer = "3.0.2"
fxhash = "0.2.1"
humantime = "2.1.0"
humantime-serde = "1.1.1"
-indexmap = "1.9.2"
+indexmap = "1.9.3"
itertools = "0.10.5"
kstring = { version = "2.0.0", features = ["arc"] }
log = { version = "0.4.17", optional = true }
nvml-wrapper = { version = "0.9.0", optional = true }
once_cell = "1.5.2"
-regex = "1.7.1"
-serde = { version = "1.0.152", features = ["derive"] }
+regex = "1.7.3"
+serde = { version = "1.0.158", features = ["derive"] }
starship-battery = { version = "0.7.9", optional = true }
sysinfo = "0.28.4"
-thiserror = "1.0.38"
+thiserror = "1.0.40"
time = { version = "0.3.20", features = ["formatting", "macros"] }
-toml_edit = { version = "0.19.4", features = ["serde"] }
+toml_edit = { version = "0.19.8", features = ["serde"] }
tui = "0.19.0"
typed-builder = "0.10.0"
unicode-segmentation = "1.10.1"
unicode-width = "0.1.10"
[target.'cfg(unix)'.dependencies]
-libc = "0.2.124"
+libc = "0.2.140"
[target.'cfg(target_os = "linux")'.dependencies]
heim = { version = "0.1.0-rc.1", features = ["disk"] }
@@ -118,20 +118,20 @@ mach2 = "0.4.1"
[target.'cfg(target_os = "windows")'.dependencies]
heim = { version = "0.1.0-rc.1", features = ["disk"] }
-windows = { version = "0.44.0", features = [
+windows = { version = "0.46.0", features = [
"Win32_Foundation",
"Win32_System_ProcessStatus",
"Win32_System_Threading",
] }
[target.'cfg(target_os = "freebsd")'.dependencies]
-serde_json = { version = "1.0.93" }
+serde_json = { version = "1.0.95" }
sysctl = { version = "0.5.4" }
filedescriptor = "0.8.2"
[dev-dependencies]
assert_cmd = "2.0.4" # cannot update this due to once_cell
-predicates = "2.1.5"
+predicates = "3.0.2"
[dev-dependencies.cargo-husky]
version = "1.5.0"