summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClementTsang <cjhtsang@uwaterloo.ca>2020-02-22 18:38:18 -0500
committerClementTsang <cjhtsang@uwaterloo.ca>2020-02-22 18:38:18 -0500
commit33a1bc159909b6f14124cac693e20b8b2e8feb51 (patch)
treeb85d47a2a73ab27caf42fd8b5d8864818ee0fd09 /Cargo.toml
parent41148a2fa2d71d0d7753d23445d1a4f06f738c3a (diff)
Add debian build.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 14 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 51dd3c62..54c1c6fa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,10 +4,10 @@ version = "0.2.1"
authors = ["Clement Tsang <cjhtsang@uwaterloo.ca>"]
edition = "2018"
repository = "https://github.com/ClementTsang/bottom"
-keywords = ["linux", "macos", "windows", "cli", "monitoring-tool", "top", "bottom", "tui"]
+keywords = ["cross-platform", "monitoring", "cli", "top", "bottom", "tui"]
license = "MIT"
categories = ["command-line-utilities", "visualization"]
-description = "A graphical top clone, written in Rust. Inspired by both gtop and gotop. Supports Linux, macOS, and Windows."
+description = "A cross-platform graphical process/system monitor with a customizable interface and a multitude of features. Supports Linux, macOS, and Windows."
readme = "README.md"
[[bin]]
@@ -43,3 +43,15 @@ serde = "1.0"
[dev-dependencies]
assert_cmd = "0.12"
predicates = "1"
+
+[package.metadata.deb]
+section = "utils"
+assets = [
+ ["target/release/btm", "usr/bin/", "755"],
+ ["LICENSE", "usr/share/doc/btm/", "644"],
+ ["README.md", "usr/share/doc/btm/README", "644"],
+]
+extended-description = """\
+By default, bottom will look for a config file in ~/.config/bottom/bottom.toml.
+If one is not specified it will fall back to defaults.
+""" \ No newline at end of file