summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClementTsang <cjhtsang@uwaterloo.ca>2020-04-26 20:18:29 -0400
committerClementTsang <cjhtsang@uwaterloo.ca>2020-04-26 20:18:29 -0400
commit24f57171251993f7188b4386e3e2ae5474def249 (patch)
treea8803e26a72a01ff69668179bba98a58ccc2e1d9 /Cargo.toml
parente33dbbd350c0fe02986c6a3248c6d1f153b2fb55 (diff)
cargo: switch to personal fork of tui-rs for now to deal with subtraction bug in lines
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 422c8ab9..ac3d4a5c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -35,7 +35,6 @@ log = "0.4.8"
regex = "1.3"
sysinfo = "0.14"
toml = "0.5.6"
-tui = {version = "0.9", features = ["crossterm"], default-features = false }
typed-builder = "0.5.1"
lazy_static = "1.4.0"
backtrace = "0.3"
@@ -43,6 +42,10 @@ serde = {version = "1.0", features = ["derive"] }
unicode-segmentation = "1.6.0"
unicode-width = "0.1.7"
+# TODO: If tui-rs doesn't update by the time we want to push, we'll have to manually re-add linear interpolation again...
+# tui = {version = "0.9", features = ["crossterm"], default-features = false }
+tui = {git = "https://github.com/ClementTsang/tui-rs", features = ["crossterm"], default-features = false }
+
[target.'cfg(windows)'.dependencies]
winapi = "0.3.8"