summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorClementTsang <cjhtsang@uwaterloo.ca>2020-05-01 23:53:29 -0400
committerClementTsang <cjhtsang@uwaterloo.ca>2020-05-02 16:01:07 -0400
commit6e81fbeebf7de91bc319b2c90cd25f18fdf288ea (patch)
treeff232af2dc4ab2705496000c779c9fd52c371ea5 /Cargo.toml
parentbb45763b39cf7a8047b0c499e6d1a2ac5f8d0847 (diff)
change: more advanced searching and filtering
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 58b5766a..ab5a1a70 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,11 +27,9 @@ crossterm = "0.17"
chrono = "0.4.11"
clap = "2.33.0"
dirs = "2.0.2"
-fern = "0.6.0"
futures = "0.3.4"
heim = "0.0.10"
itertools = "0.9.0"
-log = "0.4.8"
regex = "1.3"
sysinfo = "0.14"
toml = "0.5.6"
@@ -42,9 +40,14 @@ serde = {version = "1.0", features = ["derive"] }
unicode-segmentation = "1.6.0"
unicode-width = "0.1.7"
+# For debugging only...
+fern = "0.6.0"
+log = "0.4.8"
+
tui = {version = "0.9", features = ["crossterm"], default-features = false }
# tui = {git = "https://github.com/ClementTsang/tui-rs", features = ["crossterm"], default-features = false }
+
[target.'cfg(windows)'.dependencies]
winapi = "0.3.8"