summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 9 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 124aaafbc..1096d1ada 100644
--- a/setup.py
+++ b/setup.py
@@ -16,8 +16,13 @@ from setuptools.command.sdist import sdist
try:
from Cython.Build import cythonize
-except ImportError:
+ cythonize_import_error_msg = None
+except ImportError as exc:
+ # either there is no Cython installed or there is some issue with it.
cythonize = None
+ cythonize_import_error_msg = "ImportError: " + str(exc)
+ if "failed to map segment from shared object" in cythonize_import_error_msg:
+ cythonize_import_error_msg += " Check if the borg build uses a +exec filesystem."
sys.path += [os.path.dirname(__file__)]
@@ -79,7 +84,9 @@ else:
cython_c_files = [fn.replace(".pyx", ".c") for fn in cython_sources]
if not on_rtd and not all(os.path.exists(path) for path in cython_c_files):
- raise ImportError("The GIT version of Borg needs Cython. Install Cython or use a released version.")
+ raise ImportError("The GIT version of Borg needs a working Cython. " +
+ "Install or fix Cython or use a released borg version. " +
+ "Importing cythonize failed with: " + cythonize_import_error_msg)
cmdclass = {"build_ext": build_ext, "sdist": Sdist}