summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2022-07-05 00:16:48 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2022-07-05 00:16:48 +0200
commitff46a03b4212fab583f13ebf70ca608d268f06c4 (patch)
tree6d476681c1d16a15015341f69a3f19185e331038 /setup.py
parentf04b2bd25550b95db776f865c645e8dad8660899 (diff)
use language_level = 3str for cython
this will be the default in cython 3.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index feed325ca..b0b380354 100644
--- a/setup.py
+++ b/setup.py
@@ -225,9 +225,7 @@ if not on_rtd:
if cythonize and cythonizing:
cython_opts = dict(
- # default language_level will be '3str' starting from Cython 3.0.0,
- # but old cython versions (< 0.29) do not know that, thus we use 3 for now.
- compiler_directives={'language_level': 3},
+ compiler_directives={'language_level': '3str'},
)
if not is_win32:
# compile .pyx extensions to .c in parallel, does not work on windows