summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorManu <manu@snapdragon.cc>2022-03-23 17:28:27 +0400
committerManu <manu@snapdragon.cc>2022-03-23 17:28:27 +0400
commite686ec0d8c6e1e699ace85aa142c2dc124e886ea (patch)
tree8099812c48b91c14efd8a39e5d5d21ee58c37837 /setup.py
parent249de7eb45bcf5129f559bda40447cde9be4a75a (diff)
Fix openssl ext
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 6 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 88cf39ff0..2bc3e5f31 100644
--- a/setup.py
+++ b/setup.py
@@ -153,13 +153,15 @@ if not on_rtd:
return pc.parse(lib_pkg_name)
raise Exception(f'Could not find {lib_name} lib/headers, please set {prefix_env_var}')
+ if is_win32:
+ crypto_ext_lib = lib_ext_kwargs(
+ pc, 'BORG_OPENSSL_PREFIX', 'libcrypto', 'libcrypto', '>=1.1.1', lib_subdir='')
+ else:
+ crypto_ext_lib = lib_ext_kwargs(pc, 'BORG_OPENSSL_PREFIX', 'crypto', 'libcrypto', '>=1.1.1')
crypto_ext_kwargs = members_appended(
dict(sources=[crypto_ll_source, crypto_helpers]),
- if is_win32:
- lib_ext_kwargs(pc, 'BORG_OPENSSL_PREFIX', 'libcrypto', 'libcrypto', '>=0', lib_subdir=''),
- else:
- lib_ext_kwargs(pc, 'BORG_OPENSSL_PREFIX', 'crypto', 'libcrypto', '>=0'),
+ crypto_ext_lib,
dict(extra_compile_args=cflags),
)