summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorTW <tw@waldmann-edv.de>2022-07-05 02:46:43 +0200
committerGitHub <noreply@github.com>2022-07-05 02:46:43 +0200
commitdbb9f62afd0968b0e6698e54685512d9fb82aea4 (patch)
tree2f8cf120bae1e4844bec0e72d605240c1c923b26 /setup.py
parentcb5b1d7dcba8fe805569d30eba947b1a8c2e04c3 (diff)
parentdbb63f874bb50b5978f56af0580fcb05a729973c (diff)
Merge pull request #6836 from ThomasWaldmann/cleanups
Cleanups
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index f962e2c49..f2efad233 100644
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,7 @@ except ImportError:
multiprocessing = None
from setuptools.command.build_ext import build_ext
-from setuptools import setup, find_packages, Extension, Command
+from setuptools import setup, Extension, Command
from setuptools.command.sdist import sdist
try:
@@ -224,9 +224,7 @@ if not on_rtd:
if cythonize and cythonizing:
cython_opts = dict(
- # default language_level will be '3str' starting from Cython 3.0.0,
- # but old cython versions (< 0.29) do not know that, thus we use 3 for now.
- compiler_directives={'language_level': 3},
+ compiler_directives={'language_level': '3str'},
)
if not is_win32:
# compile .pyx extensions to .c in parallel, does not work on windows