summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2022-04-14 19:16:25 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2022-04-14 19:31:55 +0200
commitbe9e7d37c250426d26f545172ecf04b07826f3d4 (patch)
tree89d98e48c45e34ad52f5eaddd38fc71c7122be04 /setup.py
parentc592b202623f534930172670f67b793646b81b14 (diff)
remove libressl support
currently it does not have what we need, so we can simplify our code.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 083b50f1d..2d91a6a47 100644
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,6 @@ cflags = [
compress_source = 'src/borg/compress.pyx'
crypto_ll_source = 'src/borg/crypto/low_level.pyx'
-crypto_helpers = 'src/borg/crypto/_crypto_helpers.c'
chunker_source = 'src/borg/chunker.pyx'
hashindex_source = 'src/borg/hashindex.pyx'
item_source = 'src/borg/item.pyx'
@@ -171,7 +170,7 @@ if not on_rtd:
pc, 'BORG_OPENSSL_PREFIX', 'crypto', 'libcrypto', '>=1.1.1')
crypto_ext_kwargs = members_appended(
- dict(sources=[crypto_ll_source, crypto_helpers]),
+ dict(sources=[crypto_ll_source]),
crypto_ext_lib,
dict(extra_compile_args=cflags),
dict(extra_link_args=crypto_ldflags),