summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2016-05-20 22:48:57 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2016-05-20 22:48:57 +0200
commitb8303a38bf9f42e5dd69620a50a2d0afdde92428 (patch)
tree2423e6ac8d61bcf803fbbd6573c28d6a5872c4c1 /setup.py
parent956f76c6903df0955b5b6d0f9137631cf42ec0e7 (diff)
parent21a30269c2c8b967e0a01334f4540b762ce56255 (diff)
Merge branch '1.0-maint'
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a11de388b..2ded99080 100644
--- a/setup.py
+++ b/setup.py
@@ -26,12 +26,18 @@ install_requires = ['msgpack-python>=0.4.6', ]
extras_require = {
# llfuse 0.40 (tested, proven, ok), needs FUSE version >= 2.8.0
# llfuse 0.41 (tested shortly, looks ok), needs FUSE version >= 2.8.0
+ # llfuse 0.41.1 (tested shortly, looks ok), needs FUSE version >= 2.8.0
# llfuse 0.42 (tested shortly, looks ok), needs FUSE version >= 2.8.0
# llfuse 1.0 (tested shortly, looks ok), needs FUSE version >= 2.8.0
# llfuse 2.0 will break API
'fuse': ['llfuse<2.0', ],
}
+if sys.platform.startswith('freebsd'):
+ # while llfuse 1.0 is the latest llfuse release right now,
+ # llfuse 0.41.1 is the latest release that actually builds on freebsd:
+ extras_require['fuse'] = ['llfuse==0.41.1', ]
+
from setuptools import setup, Extension
from setuptools.command.sdist import sdist
@@ -84,7 +90,7 @@ except ImportError:
from distutils.command.build_ext import build_ext
if not on_rtd and not all(os.path.exists(path) for path in [
compress_source, crypto_source, chunker_source, hashindex_source,
- platform_posix_source, platform_linux_source, platform_freebsd_source]):
+ platform_posix_source, platform_linux_source, platform_freebsd_source, platform_darwin_source]):
raise ImportError('The GIT version of Borg needs Cython. Install Cython or use a released version.')