summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2021-06-16 15:31:34 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2021-06-16 15:31:34 +0200
commitb15469c3c8085799c075c4ae7a4c0ad26f081884 (patch)
tree3f8926cac0280dac6feba8a051c4d9712b5e7229 /setup.py
parentda7dd388ca6a6293054341ea2542410b9b574f4f (diff)
drop support for py36, require py37+, fixes #5790
if you do not have python >= 3.7, you can still use borg 1.1.x or 1.0.x. another option is to use the fat binary from github releases, which includes python and all other stuff needed.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f5a832c18..7ad8f8141 100644
--- a/setup.py
+++ b/setup.py
@@ -271,7 +271,6 @@ setup(
'Operating System :: POSIX :: Linux',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
@@ -300,5 +299,5 @@ setup(
setup_requires=['setuptools_scm>=1.7'],
install_requires=install_requires,
extras_require=extras_require,
- python_requires='>=3.6',
+ python_requires='>=3.7',
)