summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2022-03-02 02:37:00 +0100
committerThomas Waldmann <tw@waldmann-edv.de>2022-03-13 21:39:34 +0100
commit98a675f62a2fdc0790ba60008974c1ad17690186 (patch)
treed411b0da8b8fa987737580a451f842df58c05219 /setup.py
parentd9d1e44b6724377488fc2f16d4b390f902a3f44b (diff)
use crc32 from libdeflate, remove bundled crc32 code
we use zlib.crc32 (macOS) or libdeflate_crc32 (Linux and all others) now.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a5fb1d1f1..104ee10e4 100644
--- a/setup.py
+++ b/setup.py
@@ -48,6 +48,9 @@ system_prefix_libzstd = os.environ.get('BORG_LIBZSTD_PREFIX')
# needed: xxhash (>= 0.8.1)
system_prefix_libxxhash = os.environ.get('BORG_LIBXXHASH_PREFIX')
+# needed: deflate (>= 1.5)
+system_prefix_libdeflate = os.environ.get('BORG_LIBDEFLATE_PREFIX')
+
# Number of threads to use for cythonize, not used on windows
cpu_threads = multiprocessing.cpu_count() if multiprocessing and multiprocessing.get_start_method() != 'spawn' else None
@@ -194,6 +197,7 @@ if not on_rtd:
checksums_ext_kwargs = members_appended(
dict(sources=[checksums_source]),
setup_checksums.xxhash_ext_kwargs(pc, system_prefix_libxxhash),
+ setup_checksums.deflate_ext_kwargs(pc, system_prefix_libdeflate),
dict(extra_compile_args=cflags),
)