summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2016-06-04 15:53:30 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2016-06-04 15:53:30 +0200
commit8e7ed8ebea357ce6e4dd0a6d64d872bec53c2156 (patch)
treed4d84b50e8d348cfc2fe17e4b0e11865f0ddc8bb /setup.py
parent21a30269c2c8b967e0a01334f4540b762ce56255 (diff)
llfuse: update version requirement for freebsd
as the requirement string is a AND operation, I used the rough "<2.0" requirement and then excluded the non-working versions.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 94331086e..6312aee09 100644
--- a/setup.py
+++ b/setup.py
@@ -32,9 +32,9 @@ extras_require = {
}
if sys.platform.startswith('freebsd'):
- # while llfuse 1.0 is the latest llfuse release right now,
- # llfuse 0.41.1 is the latest release that actually builds on freebsd:
- extras_require['fuse'] = ['llfuse==0.41.1', ]
+ # llfuse was frequently broken / did not build on freebsd
+ # llfuse 0.41.1, 1.1 are ok
+ extras_require['fuse'] = ['llfuse <2.0, !=0.42.*, !=0.43, !=1.0', ]
from setuptools import setup, Extension
from setuptools.command.sdist import sdist