summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBjörn Ketelaars <bjorn.ketelaars@hydroxide.nl>2023-09-11 21:43:35 +0200
committerBjörn Ketelaars <bjorn.ketelaars@hydroxide.nl>2023-09-11 21:43:35 +0200
commit83d4fca4d275adc55a8369ef3bca969f0057f58b (patch)
tree10d888342903780d546c05e82db39e4ee4729b43 /setup.py
parenta089448841ddfbfa7674da18ff417f10a3191f4f (diff)
OpenBSD only: switch to OpenSSL-3.0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 95d180c65..d9c0fee5c 100644
--- a/setup.py
+++ b/setup.py
@@ -161,8 +161,8 @@ if not on_rtd:
# Use openssl (not libressl) because we need AES-OCB via EVP api. Link
# it statically to avoid conflicting with shared libcrypto from the base
# OS pulled in via dependencies.
- crypto_ext_lib = {"include_dirs": ["/usr/local/include/eopenssl11"]}
- crypto_extra_objects += ["/usr/local/lib/eopenssl11/libcrypto.a"]
+ crypto_ext_lib = {"include_dirs": ["/usr/local/include/eopenssl30"]}
+ crypto_extra_objects += ["/usr/local/lib/eopenssl30/libcrypto.a"]
else:
crypto_ext_lib = lib_ext_kwargs(pc, "BORG_OPENSSL_PREFIX", "crypto", "libcrypto", ">=1.1.1")