summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2020-10-04 20:36:31 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2020-10-05 00:23:40 +0200
commit7dc161067498703dca27b6e2437548a9cc4d981b (patch)
treec4ad1c002a1850c79105cd90d8dd53fec2defba9 /setup.py
parent1562952adafe69cb6101cb5ce4492478747af58a (diff)
selecting least broken llfuse version
1.3.6: works on all supported OSes, but not on py39 1.3.7: does not work on FreeBSD, but with py39
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b220bc6dd..d4992067c 100644
--- a/setup.py
+++ b/setup.py
@@ -83,8 +83,8 @@ install_requires = [
# if you do not have llfuse, do not require it, most of borgbackup will work.
extras_require = {
'fuse': [
- 'llfuse >=1.3, <2.0',
- 'llfuse >=1.3.4, <2.0; python_version >="3.7"',
+ 'llfuse >=1.3.4, <1.3.7; python_version <"3.9"', # broken on py39
+ 'llfuse >=1.3.7, <2.0; python_version >="3.9"', # broken on freebsd
],
}