summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2024-01-02 19:30:14 +0100
committerThomas Waldmann <tw@waldmann-edv.de>2024-01-02 19:30:14 +0100
commit5ca4703a47cb270e6f08f91c98b3e71ce1c2ce49 (patch)
tree7570173a4764b3fb8e2dd97443c104da6ef8c09c /setup.py
parent1432f547fe4fe13386b245dcc0d9c2a0880ddfe6 (diff)
use and require cython3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4bffc8d3d..c59f54e3a 100644
--- a/setup.py
+++ b/setup.py
@@ -239,6 +239,8 @@ if not on_rtd:
)
if cythonize and cythonizing:
+ # 3str is the default in Cython3 and we do not support older Cython releases.
+ # we only set this to avoid the related FutureWarning from Cython3.
cython_opts = dict(compiler_directives={"language_level": "3str"})
if not is_win32:
# compile .pyx extensions to .c in parallel, does not work on windows