summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2022-07-04 20:26:42 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2022-07-04 20:33:59 +0200
commit5c8a5f111f5cf4a16ea72b76a5335a7b35259e18 (patch)
treef48623878b5b1abab75e42740867c3c276cc2017 /setup.py
parent820a927b06006badf26c66b8b995b9097195039f (diff)
stop using libdeflate
borg2's new repo format does not need computing crc32 over big amounts of (content) data any more (we now use xxh64 for that). thus, having a quick crc32 implementation via libdeflate is not important enough any more to rectify having libdeflate as a requirement.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2d91a6a47..f962e2c49 100644
--- a/setup.py
+++ b/setup.py
@@ -186,7 +186,6 @@ if not on_rtd:
checksums_ext_kwargs = members_appended(
dict(sources=[checksums_source]),
lib_ext_kwargs(pc, 'BORG_LIBXXHASH_PREFIX', 'xxhash', 'libxxhash', '>= 0.7.3'),
- lib_ext_kwargs(pc, 'BORG_LIBDEFLATE_PREFIX', 'deflate', 'libdeflate', '>= 1.5'),
dict(extra_compile_args=cflags),
)