summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2015-09-13 00:58:57 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2015-09-13 00:58:57 +0200
commit2b311846e08f5b42ced5c9fddecda9723d52d4fb (patch)
treec7e2ef20ac2832273214516d8122878498d5633a /setup.py
parent7774d4f82ce620abdcc2389ecb9f77a8fbc3070a (diff)
add a argparse.py (from py 3.2.6) that is not broken
also: remove previois attempt to fix this, installing pypi argparse into virtualenv does not work.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 1 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index f59c734d9..c68b9651b 100644
--- a/setup.py
+++ b/setup.py
@@ -14,12 +14,6 @@ if my_python < min_python:
# Also, we might use some rather recent API features.
install_requires=['msgpack-python>=0.4.6', ]
-if (my_python < (3, 2, 4) or
- (3, 3, 0) <= my_python < (3, 3, 1)):
- # argparse in stdlib does not work there due to a bug,
- # pull a fixed argparse from pypi
- install_requires.append("argparse>=1.4.0")
-
from setuptools import setup, Extension
from setuptools.command.sdist import sdist
@@ -161,7 +155,7 @@ setup(
'Topic :: Security :: Cryptography',
'Topic :: System :: Archiving :: Backup',
],
- packages=['borg', 'borg.testsuite'],
+ packages=['borg', 'borg.testsuite', 'borg.support', ],
entry_points={
'console_scripts': [
'borg = borg.archiver:main',