summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrey Bienkowski <hexagon-recursion@posteo.net>2022-02-25 07:52:50 +0300
committerAndrey Bienkowski <hexagon-recursion@posteo.net>2022-02-25 07:52:50 +0300
commit142bb0e3d4aa2b689489b772501a4186b8f4470b (patch)
treecea70a57a7464429ec946326fc1e334904d35b9e /setup.py
parent6cbb7d650fcab4181429572b199267c40c066796 (diff)
setup.py: add parent to sys.path
When using pyproject.toml the parent of setup.py is not on sys.path by default. See <https://github.com/pypa/setuptools/discussions/3134>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 98a844269..977035d7d 100644
--- a/setup.py
+++ b/setup.py
@@ -19,6 +19,7 @@ try:
except ImportError:
cythonize = None
+sys.path += [os.path.dirname(__file__)]
import setup_checksums
import setup_compress
import setup_crypto