summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2016-05-06 14:55:27 +0200
committerThomas Waldmann <tw@waldmann-edv.de>2016-05-06 14:56:54 +0200
commit0fa663febe59bc3a8857300bdea6beb139a737df (patch)
tree8c49194cd2a0c42e3cc3b732db375ce802a4b504 /setup.py
parentd22bbe17c56a597c02763798e30f0c6da439425b (diff)
seek /opt/pkg (pkgsrc OS X) for openssl and lz4
Add /opt/pkg (used by pkgsrc on Mac OS X) to possible openssl and lz4 header path. from 2015Q2 onwards the prefix has changed to /opt/pkg in order to be compatible with El Capitan's "System Integrity Protection" feature. -- pkgsrc.joynet.com thanks to @weakish for finding this!
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7223a0eb5..741070cc5 100644
--- a/setup.py
+++ b/setup.py
@@ -106,7 +106,8 @@ def detect_lz4(prefixes):
include_dirs = []
library_dirs = []
-possible_openssl_prefixes = ['/usr', '/usr/local', '/usr/local/opt/openssl', '/usr/local/ssl', '/usr/local/openssl', '/usr/local/borg', '/opt/local']
+possible_openssl_prefixes = ['/usr', '/usr/local', '/usr/local/opt/openssl', '/usr/local/ssl', '/usr/local/openssl',
+ '/usr/local/borg', '/opt/local', '/opt/pkg', ]
if os.environ.get('BORG_OPENSSL_PREFIX'):
possible_openssl_prefixes.insert(0, os.environ.get('BORG_OPENSSL_PREFIX'))
ssl_prefix = detect_openssl(possible_openssl_prefixes)
@@ -116,7 +117,8 @@ include_dirs.append(os.path.join(ssl_prefix, 'include'))
library_dirs.append(os.path.join(ssl_prefix, 'lib'))
-possible_lz4_prefixes = ['/usr', '/usr/local', '/usr/local/opt/lz4', '/usr/local/lz4', '/usr/local/borg', '/opt/local']
+possible_lz4_prefixes = ['/usr', '/usr/local', '/usr/local/opt/lz4', '/usr/local/lz4',
+ '/usr/local/borg', '/opt/local', '/opt/pkg', ]
if os.environ.get('BORG_LZ4_PREFIX'):
possible_lz4_prefixes.insert(0, os.environ.get('BORG_LZ4_PREFIX'))
lz4_prefix = detect_lz4(possible_lz4_prefixes)