summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMarian Beermann <public@enkore.de>2016-05-25 22:01:38 +0200
committerMarian Beermann <public@enkore.de>2016-05-25 22:01:38 +0200
commit0e3bba7b640269595b2ed791fa2b9b18dd006bb7 (patch)
treeb0f2edf0a32dcb83ec59132e19c5055e277dbd29 /setup.py
parent4302ffbdbc08a43a59001ffd3e184f4caef330af (diff)
Don't rebuild command line parser for each invocation
Makes tests faster
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2ded99080..4f0159acc 100644
--- a/setup.py
+++ b/setup.py
@@ -159,7 +159,7 @@ class build_usage(Command):
print('generating usage docs')
# allows us to build docs without the C modules fully loaded during help generation
from borg.archiver import Archiver
- parser = Archiver().build_parser(prog='borg')
+ parser = Archiver(prog='borg').parser
choices = {}
for action in parser._actions:
if action.choices is not None: