summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..dcc7bfd
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,42 @@
+# -*- Makefile -*-
+
+bin_PROGRAMS = bmon
+
+bmon_CFLAGS = \
+ -I${top_srcdir}/include \
+ -I${top_builddir}/include \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -D_GNU_SOURCE \
+ $(CURSES_CFLAGS) \
+ $(CONFUSE_CFLAGS) \
+ $(LIBNL_CFLAGS) \
+ $(LIBNL_ROUTE_CFLAGS)
+
+bmon_LDADD = \
+ $(CURSES_LIB) \
+ $(CONFUSE_LIBS) \
+ $(LIBNL_LIBS) \
+ $(LIBNL_ROUTE_LIBS)
+
+bmon_SOURCES = \
+ utils.c \
+ unit.c \
+ conf.c \
+ input.c \
+ output.c \
+ group.c \
+ element.c \
+ attr.c \
+ element_cfg.c \
+ history.c \
+ graph.c \
+ bmon.c \
+ module.c \
+ in_netlink.c \
+ in_null.c \
+ in_dummy.c \
+ in_proc.c \
+ out_null.c \
+ out_format.c \
+ out_ascii.c \
+ out_curses.c