summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2019-08-31 15:37:46 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2019-08-31 15:37:46 +0300
commit31bf144ecdfa3c1da9e38e1f6338329aab996680 (patch)
treeb0aaaa045905bb78adc6e60af16b867e93c4e371 /Cargo.toml
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..b3aa1cb
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "bb"
+version = "0.1.0"
+authors = ["Manos Pitsidianakis <el13635@mail.ntua.gr>"]
+edition = "2018"
+build = "build.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[[bin]]
+name = "bb"
+path = "src/main.rs"
+
+[dependencies]
+crossbeam = "0.7"
+signal-hook = "0.1.10"
+termion = "1.5.3"
+libc = "0.2.62"
+unicode-segmentation = "1.2.1"
+nix = "0.15.0"
+
+[profile.release]
+opt-level = 'z' # Optimize for size.
+lto = true
+codegen-units = 1
+panic = 'abort'