summaryrefslogtreecommitdiffstats
path: root/tests/syntax-tests/highlighted/nix/test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/syntax-tests/highlighted/nix/test.nix')
-rw-r--r--tests/syntax-tests/highlighted/nix/test.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/syntax-tests/highlighted/nix/test.nix b/tests/syntax-tests/highlighted/nix/test.nix
new file mode 100644
index 00000000..bf86676a
--- /dev/null
+++ b/tests/syntax-tests/highlighted/nix/test.nix
@@ -0,0 +1,15 @@
+{ nixpkgs ? <nixpkgs>
+, nixpkgs' ? import nixpkgs {}}: with nixpkgs';
+
+# some comment
+stdenv.mkDerivation rec {
+ pname = "test";
+ version = "0.2.3";
+ name = "${pname}-${version}";
+
+ buildInputs = [
+ gzip
+ bzip2
+ python27
+ ];
+}