summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f4862c40..f3d1197d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,13 +17,14 @@ default = ["application"]
# bat as a library.
application = [
"atty",
+ "bugreport",
"clap",
"dirs-next",
"git",
"lazy_static",
"paging",
- "wild",
"regex-onig",
+ "wild",
]
git = ["git2"] # Support indicating git modifications
paging = ["shell-words"] # Support applying a pager on the output
@@ -50,7 +51,7 @@ serde_yaml = "0.8"
semver = "1.0"
path_abs = { version = "0.5", default-features = false }
clircle = "0.3"
-bugreport = "0.4"
+bugreport = { version = "0.4", optional = true }
dirs-next = { version = "2.0.0", optional = true }
grep-cli = "0.1.6"