summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@gmail.com>2020-03-30 10:37:29 -0700
committerDavid Peter <sharkdp@users.noreply.github.com>2020-03-31 09:27:56 +0200
commit4e11abdf9b0b28dfda2ec4904ddf0a82e524a847 (patch)
tree7ac76bbd0bcbb6df27393708f87852cebbc89fd9 /Cargo.toml
parent570805bc985227a8e612878d8f62becd70b7b16a (diff)
Move git changes support behind a feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d7ba56b2..c9bd3ad9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,10 +23,12 @@ application = [
"atty",
"clap",
"dirs",
+ "git",
"lazy_static",
"liquid",
"wild",
]
+git = ["git2"] # Support indicating git modifications
[dependencies]
atty = { version = "0.2.14", optional = true }
@@ -44,6 +46,7 @@ globset = "0.4"
[dependencies.git2]
version = "0.13"
+optional = true
default-features = false
[dependencies.syntect]