summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorsharkdp <davidpeter@web.de>2020-03-31 09:56:27 +0200
committerDavid Peter <sharkdp@users.noreply.github.com>2020-04-11 10:33:53 +0200
commit9793bb3938820f2fdea32c1e17fe360753538fba (patch)
tree780d16186ca6eefcd48add549f57284c5eb069d6 /Cargo.toml
parent496dd29cb96f79e9ac77668c685bd248849cfd4b (diff)
Update to syntect 4.1, fancy-regex support
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 24462d10..65fdba02 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,9 +28,12 @@ application = [
"liquid",
"paging",
"wild",
+ "regex-onig",
]
git = ["git2"] # Support indicating git modifications
paging = ["shell-words"] # Support applying a pager on the output
+regex-onig = ["syntect/regex-onig"] # Use the "oniguruma" regex engine
+regex-fancy = ["syntect/regex-fancy"] # Use the rust-only "fancy-regex" engine
[dependencies]
atty = { version = "0.2.14", optional = true }
@@ -52,7 +55,7 @@ optional = true
default-features = false
[dependencies.syntect]
-version = "3.2.0"
+version = "4.1.0"
default-features = false
features = ["parsing", "yaml-load", "dump-load", "dump-create"]