summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@gmail.com>2020-03-30 10:36:26 -0700
committerDavid Peter <sharkdp@users.noreply.github.com>2020-03-31 09:27:56 +0200
commit014d7545889667e62eb30f6a5717f00a90616c06 (patch)
treef5b9136f02293df65801e49bf7b14c704c3d0449 /Cargo.toml
parent4e11abdf9b0b28dfda2ec4904ddf0a82e524a847 (diff)
Move paging support behind a feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c9bd3ad9..98f76e41 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,9 +26,11 @@ application = [
"git",
"lazy_static",
"liquid",
+ "paging",
"wild",
]
git = ["git2"] # Support indicating git modifications
+paging = ["shell-words"] # Support applying a pager on the output
[dependencies]
atty = { version = "0.2.14", optional = true }
@@ -40,7 +42,7 @@ lazy_static = { version = "1.4", optional = true }
wild = { version = "2.0", optional = true }
content_inspector = "0.2.4"
encoding = "0.2"
-shell-words = "0.1.0"
+shell-words = { version = "0.1.0", optional = true }
unicode-width = "0.1.7"
globset = "0.4"